Overview
When using your existing company domain or external email address (e.g., support@[yourcompany].com) instead of using the Kayako email address (e.g., support@[yourcompany].Kayako.com) as your email channel in Kayako, at times, your messages may end up being caught in your customers' spam filters. This is a common reason why it may seem that emails you are sending in Kayako are not reaching your recipient's inbox.
Diagnosis
There are several reasons why an email could end up in the recipient's spam folder. If they have implemented rigorous spam filtering rules, and if your email has been marked as spam, then there's a likelihood that your email will end up in the spam folder. You may wonder why an email could be marked as spam even if it's a legitimate one. Well, there are also several reasons why this could happen.
One of the most common reasons is email spoofing, which is the creation of email messages with a forged sender address. Another reason is your IP address may have been used by someone else for spam. So even if you did not send spam emails, your emails could get flagged as spam if you are using the same IP address that was used for sending spam messages.
When using your own domain or email address in Kayako Classic, we strongly recommend setting up SPF (Sender Policy Framework) protection to ensure that your emails are delivered successfully.
Prerequisites
- Administrative access to your email server is required to enable SPF.
Solution
SPF (Sender Policy Framework) is an anti-spam technique used by some modern email services to ensure the email they are receiving is really coming from your email server.
An entry is placed on your domains DNS (Domain Name Service) records. This record holds the IP address of the email servers which are authorized to send a legitimate email for your domain. When an email server receives an email, it will look up the IP listed on this record, and will then compare that IP to the IP of the connecting server. If they are different, it will know the connection is not authorized and will terminate the connection. If they match, it will receive the email.
Setting up SPF for Kayako Download
Add a new TXT record to your email domains DNS record, the record you need to add depends on your mail servers IP address:
- Sign in to the DNS provider for your domain.
- Open your DNS records for editing.
- We must add Kayako to the list of approved senders, which can be done one of two ways, depending on your needs:
- For the internal-only mail routing (within the Kayako domain) add your mail servers IP address to your SPF record. If your mail servers IP address is 100.200.100.200, the SPF record you would need to add to your domain's DNS would be:
-
MyEmailDomain.com. IN TXT "v=spf1 mx ip4:100.200.100.200 ~all"
NOTE: Replace MyEmailDomain with your domain name.
- For external mail routing (using your domain to send emails outside of Kayako), you would need you to add both the IP of your mail server and your Kayako server. For example, if your mail server's IP address is 100.200.100.100, and the IP of your Kayako server 100.300.200.200, then the resulting SPF record would be:
MyEmailDomain.com. IN TXT "v=spf1 mx ip4:100.200.100.200 ip4:100.300.200.200 ~all"
NOTE: Replace the MyEmailDomain with your domain name.
- Save your changes.
Confirmation
Once you have completed the SPF authentication, your email should be delivered to your customers' inbox instead of getting caught in their spam folders.